I have recently updated my Java and now receive one of the following errors:1. Error: Could not find Java SE Runtime Environment.2. Error: Could not find java.dll3. Error: Registry key Software\JavaSoft\Java Runtime Environment \CurrentVersion has value 1.8 , but 1.7 is required.What should I do?

I have recently updated my Java and now receive one of the following errors: 1. Error: Could not find Java SE Runtime Environment. 2. Error: Could not find java.dll 3. Error: Registry key 'Software\JavaSoft\Java Runtime Environment'\CurrentVersion' has value '1.8', but '1.7' is required. What should I do?

We have found that if there are multiple versions of Java installed on the computer the above errors do occur.

Please try the following:

  1. From your desktop, click on the Start Menu (or Start ball) at the lower left of your screen. 
  2. Go to the Control Panel.
  3. Click on Programs and Features.
  4. Select Java and click UninstallIMPORTANT: You must uninstall ALL instances of Java.
  5. IMPORTANT: Restart your computer.
  6. Install Java from the link http://java.com/en/download/index.jsp (A jxpiinstall.exe file will download to your computer. Click on this file to install Java.)
Topic Information
  • Topic #: 15113-1600
  • Date Created: 11/07/2014
  • Last Modified Since: 08/19/2015
  • Viewed: 34474